Sign In

PROVEtech:RBS (System) by AKKA - Toolkit for LabVIEW Download

Full AUTOSAR V4.x Bus Communication Simulation in LabVIEW

* 0 ↓186
 logo
Version21.0.0.12
ReleasedJan 28, 2021
Publisher AKKA
LicenseAKKA Terms of Use
LabVIEW VersionLabVIEW>=0
Operating System Windows
Project links Homepage  

Description

Start LabVIEW and VI Package Manager with administrator privileges.

Requires NI License Manager 4.5 or later (https://www.ni.com/en-us/support/downloads/software-products/download.ni-license-manager.html).
Requires Microsoft Visual C++ Redistributable für Visual Studio 2015, 2017 und 2019 (https://support.microsoft.com/de-de/help/2977003/the-latest-supported-visual-c-downloads)

- Provides a solution for automotive bus communication for LabVIEW
- Supports CAN, CAN-FD, Automotive Ethernet (SOME/IP, SOME/IP-SD), LIN, and FlexRay
- Supports event-based and time triggered communication
- Supports different bus description format files: .dbc, .ldf, and AUTOSAR XML
- Deployable on all NI targets (Windows, PharLap, NI Linux Real-Time) with NI-XNET bus interfaces
- Offers short integration and configuration times

NOTE - Usage on Real-Time system:
Installation
1. Start VIPM and LabVIEW both as Administrator
2. Install .vip
3. Copy "C:\Program Files\National Instruments\RT Feeds\provetechrbs-api_x.x.x.x_x64.ipk" to "/home/admin" on RT system using SFTP tool
4. Make sure RT target is connected to internet
5. SSH into target, run: opkg install provetechrbs-api_x.x.x.x_x64.ipk
6. Reboot RT target
7. For NI real-time targets an additional license is used.
a. Run *Examples\Signals Single Point CAN.vi* in a new real-time project. This will create ""/tmp/\.seed".
b. Obtain a valid license key file by emailing your RBS serial number, the desired modules (CAN, LIN, FlexRay, Ethernet) and the file "/tmp/\.seed" to provetech-rbs@akka.eu.
c. Copy a valid *.key file to "/home/admin".
d. Run example again.

Release Notes

21.0.0.12 (Jan 28, 2021)

- Support of XNET IP stack for automotive ethernet (requires XNET >= 20.5, NI PXIe-8521/8522)
- Support for LabVIEW RT (Linux x64) - ipk installer

- Updated PDF manual
- Updated Configurator
- Updated RBS Core libraries
- Improved error handling in read and write VIs
- Bugfix: License check for Ethernet and FlexRay is swapped


Install with VIPM Download Package

Note, you must have the VIPM Desktop app to install this package into LabVIEW.

Versions

  Post an Idea   Post a Resource

Recent Posts