Sign Up

Details

Hi James,
I don't know if you're still supporting this library, but it would be great if scram-sha-256 authentication support was added so your toolkit can be used with the latest version of PostgreSQL.

When trying to connect to new DBs using the latest version of PostgreSQL we get the following error message: CONNECTION_BAD: authentication method 10 not supported. After a quick Google it seems to be caused by the new password encryption.

Comments

Tom McQuillan Just an update, I just replaced the libPQ library on disk (and the DLLs it's dependent on) and it "just worked"!
 •  Reply34m

Please sign in to leave a comment.