Sign Up

OpenG String Library by OpenG - Toolkit for LabVIEW Download

OpenG String Library

D Discussion Watch * 6 ↓96,689
 screenshot
Version6.0.2.35
ReleasedApr 02, 2024
Publisher OpenG
License BSD-3-clause
LabVIEW VersionLabVIEW>=20.0
Operating System Windows, Mac, and Linux
Dependencies oglib_error   oglib_lvdata  
Used By lavag_lib_ui_tools_controls_addon   labview_open_source_project_lib_certification_authority   lava_lib_ui_tools   nevstop_lib_csm_api_string_arguments_support   euv_tech_lib_dvr_helper   oglib_variantconfig   hooovahh_copy_and_zip_with_progress   lava_lib_labview_task_manager   labview_open_source_project_lib_serializer_easyxml   jki_lib_gla_2020_weaver_ioc_container   labview_version_selector   jki_lib_vi_tester_junit_xml_results   hooovahh_variant_repository   nevstop_3rdparty_dependencies   sas_workshops_lib_vitester_for_g_cli   jki_lib_easyxml   hooovahh_file_io   oglib_file   oglib_array   lavag_lib_user_interface_xcontrole_multi_segment_ramp_xcontrol   jki_state_machine_editor   ogrsc_package_builder   jki_lib_caraya   jki_lib_python_bridge_for_labview   jki_lib_smo_editor   openg.org_lib_openg_toolkit   lava_lib_json_api   nevstop_lib_csm_ini_static_variable_support   hooovahh_array_vims   labview_quickdrops_manager   blue_origin_lib_blue_event_log_opensource  
Project links Homepage   Repository   Discussion

Description

The OpenG String Library package contains several routines for operating on strings.

Release Notes

6.0.2.35 (Apr 02, 2024)

- [6.0.2] Hotfix to upgrade dependency on new OpenG Variant Data Library
- [6.0.1] Hotfix to remove "__ogtk" suffix from lvlib name
- Requires LabVIEW 2020 or greater
- Moved library VIs into Library (`openg_string.lvlib`) #10
- Upgraded source code to LV2020 format #8
- Marked all as Separate Compiled Code #9

Kudos to contributors @Bas-vE and @jimkring for their work on this release.

Important: Callers of this package will relink automatically to the new Library (`openg_string.lvlib) that contains this package. However, if you subsequently downgrade this package to version 5.x or older, your callers will need to be manually relinked to the older version (without the Library namespace).

jimkring was a contributor to this release


Download Package

Versions
All Contributors

  Post an Idea   Post a Resource

Recent Posts